令和3年度春期 ネットワークスペシャリスト OSPF検証

ネットワーク

昨日ネットワークスペシャリストを受験しました。
午後1にでてきたOSPFについて早速試してみたので共有します。

※これが間違っている可能性もありますので参考までに皆様でも検証していただければと思います。


2021/06/22更新!
IPAの公式の回答が出ました。
このページで検証した内容で合っていました!
受かりますように…

2021/06/25更新!
受かりました!うれしい。


OSPF検証

感想

とりあえず感想ですが、午前2は84%で通りましたが問題は午後です。
午後1では1,2を選択し、午後2では1を選択しました。

午後1については結構難しいという意見が多く見えた気がしました。
自分は仮想リンクという言葉は出てきませんでしたが、
マルチホップセッションのBGPに近いような何かがあったはず。
と近いところまでは導けた気がします。

午後2については簡単という意見が見えましたが、自分は設問6の移行が大変でした。
というのも最初の構成の図と最後の構成の図を見比べるのにページをめくるのが大変で。。。
という言い訳はさておき、合格可能性は五分五分ってところなので神に祈ります。

ネスペ(令和3年度春)

問題文の構成を作ってみました。※リソースの関係で一部省略してます。

問題についてはこちら

IPA 独立行政法人 情報処理推進機構:問題冊子・配点割合・解答例・採点講評(2021、令和3年)

簡単に言うと、会社を統合する際に同じエリア0を追加するが、直接接続ができません。
どうしましょうってやつ。

これはVirtual Linkという機能を使うらしい。
普段からお世話になっている「ネットワークエンジニアとして」がわかりやすい。

OSPF - 仮想リンク(バーチャルリンク)の設定
OSPF - 仮想リンク(バーチャルリンク)の設定

検証

まずはIPアドレスを割り当てる。

初期構成

セグメント機器IFIPMaskrouter-id
mFWG0/1(Internet NAPT)DHCP10.10.10.10
hFWG0/0172.17.0.1255.255.255.128
hRouterG0/1172.17.0.2255.255.255.12811.11.11.11
gRouterG0/0172.16.12.65255.255.255.192
hL3SW4e0/0172.17.0.3255.255.255.1284.4.4.4
iL3SW4lo0172.17.2.1255.255.254.0
jL3SW4lo1172.17.4.1255.255.254.0
gL3SW1e0/0172.16.12.66255.255.255.1921.1.1.1
aL3SW1lo0172.16.0.1255.255.254.0
bL3SW1lo1172.16.2.1255.255.254.0
gL3SW2e0/0172.16.12.67255.255.255.1922.2.2.2
cL3SW2lo0172.16.4.1255.255.254.0
dL3SW2lo1172.16.6.1255.255.254.0
gL3SW3e0/0172.16.12.68255.255.255.1923.3.3.3
eL3SW3lo0172.16.8.1255.255.254.0
fL3SW3lo1172.16.10.1255.255.254.0

E社統合追加(E社セグメント-172.18.0.0/16)

セグメント機器IFIPMaskrouter-id
L3SW1e0/1172.18.255.1255.255.255.252
L3SW6e0/0172.18.255.2255.255.255.2526.6.6.6
L3SW6lo0172.18.0.1255.255.254.0
L3SW6lo1172.18.2.1255.255.254.0

これらIPを各機器に割り当てる。
以下はアドレスを割り当てられた後の作業
networkコマンドを一つ一つ丁寧に入れます。

  • FW
//NAPT設定
(config)#int g0/1
(config-if)#ip nat outside
(config-if)#int g0/0
(config-if)#ip nat inside
(config-if)#exit
(config)#ip nat inside source list 1 interface g0/1 overload
(config)#access-list 1 permit any
(config)#ip route 0.0.0.0 0.0.0.0 g0/1

//OSPF設定
(config)#router ospf 1
(config-router)#network 172.17.0.0 0.0.0.127 area 0
(config-router)#router-id 10.10.10.10
(config-router)#default-information originate

IPA問題の全社のOSPFエリアからインターネットアクセスを可能にする設定に関する問題で
自分はこのNAPT設定を書いたのだが、よく考えると、デフォルトルートの広告が正しい?

  • Router
(config)#router ospf 1
(config-router)#network 172.16.12.64 0.0.0.63 area 1
(config-router)#network 172.17.0.0 0.0.0.127 area 0
(config-router)#router-id 11.11.11.11
  • L3SW4
(config)#router ospf 1
(config-router)#network 172.17.0.0 0.0.0.127 area 0
(config-router)#network 172.17.2.0 0.0.1.255 area 0
(config-router)#network 172.17.4.0 0.0.1.255 area 0
(config-router)#router-id 4.4.4.4

本社ネットワークのみ設定した状態でFWを見てみる。
エリア1からのルートはエリア間ルートなので「IA」がついている。

default-informationを入れ忘れている
  • L3SW1
(config)#router ospf 1
(config-router)#network 172.16.12.64 0.0.0.63 area 1
(config-router)#network 172.16.0.0 0.0.1.255 area 1
(config-router)#network 172.16.2.0 0.0.1.255 area 1
(config-router)#router-id 1.1.1.1
  • L3SW2
(config)#router ospf 1
(config-router)#network 172.16.12.64 0.0.0.63 area 1
(config-router)#network 172.16.4.0 0.0.1.255 area 1
(config-router)#network 172.16.6.0 0.0.1.255 area 1
(config-router)#router-id 2.2.2.2
  • L3SW3
(config)#router ospf 1
(config-router)#network 172.16.12.64 0.0.0.63 area 1
(config-router)#network 172.16.8.0 0.0.1.255 area 1
(config-router)#network 172.16.10.0 0.0.1.255 area 1
(config-router)#router-id 3.3.3.3

支社ネットワークをOSPFでつなげた後、FWで見てみる。
ここにある「IA」とはエリア間ルートであり、エリア0ではなくエリア1から得たルート。

default-informationを入れ忘れている

ルートが複数現れる。

集約について

支社へのネットワークを集約することを目的として設定をある機器に入れると、
本社のL3SWのルーティングテーブルで?.?.?.?/16が確認できるとのこと。
合っているのかはわからないが自分はABRである「ルーター」にエリア1を集約する設定を入れた。

  • Router
(config)#router ospf 1
(config-router)#area 1 range 172.16.0.0 255.255.0.0

L3SW4, FWから確認してみる。

default-informationを入れ忘れている
default-informationを入れ忘れている

このように集約された。

ループについて

次にルーティングループについて検証してみる。
まずはRouterのルーティングテーブルを確認

ルータにて172.16.0.0/16として集約して広告しているため、
このテーブルに無い、例えば172.16.20.1なんかはルーティングループが発生するはず。

と思ったら、上の画像に

O        172.16.0.0/16 is a summary, 00:05:56, Null0

が自動で追加されていた。
これのおかげでループが発生しない。
ロンゲストマッチなのでその他172.16.0.*にも影響はない。
なのでおそらくルータとFW間でループが発生するのが正解?

E社の追加(仮想リンク)

E社を追加してみる。
ここはエリア0

  • L3SW1
(config)#router ospf 1
(config-router)#network 172.18.255.0 0.0.0.3 area 0
  • L3SW6
(config)#router ospf 1
(config-router)#router-id 6.6.6.6
(config-router)#network 172.18.255.0 0.0.0.3 area 0

L3SW1でneighborを確認。

本社FWでは影響なし。

E社からは本社へのルートがない。

仮想リンクを追加する。
仮想リンクはABRに追加するため、L3SW1とルータに追加する。

// L3SW1
(config-router)#area 1 virtual-link 11.11.11.11

// Router
(config-router)#area 1 virtual-link 1.1.1.1

なにか追加された

そしてFWには集約したはずのものが復活してしまった。

これはおそらく、L3SW1でE社に向かって集約されていないから。
Routerに入れた集約の設定を同様にL3SW1にも入れてみる。

(config-router)#area 1 range 172.16.0.0 255.255.0.0

もう一度FWを見る。
集約された。
ので最後の追加の設定はL3SW1にエリア1を集約する設定とループを防ぐ設定を入れるのが正解?

E社のL3SW6からも本社、ネットワークに接続できるようになった。

まとめ

結論(自分の意見なので合っているかはわかりません)

設問3
(1) ルーティングテーブルを小さくして処理を軽量化する
(2) ルータ
(3) ルータ~FW
(4) ルータ 172.16.0.0/16
設問4
(1) h, i, j, k, l
(2)L3SW1, ルータ – エリア1をトランジットとして仮想リンク設定をする
(3)L3SW1 – エリア1を集約する設定とループを防ぐNull設定

以上が自分で試してみた内容。
これが正しいのかどうかはわからないので、是非コメント、ご指摘ください。

コメント

  1. 検証お疲れさまです。参考になります。
    設問4(3)につきまして、
    下線部⑦を含む文の一つ前の文を見ると「本社のOSPFエリア0の~」と書かれていますが、それでもL3SW1が正解でしょうか?

    • コメントありがとうございます!
      記事の途中の”そしてFWには集約したはずのものが復活してしまった。”
      のところですが、本社エリア0のFWに集約前のルートが現れました。
      なので本社OSPFエリア0に支社個別経路が現れてしまったことになります。
      こちらで回答になっていますでしょうか?

      • 追記でL3SW1に集約の設定を入れたところ本社エリア0でも集約された状態に戻りましたので
        L3SW1ではないかと考えています。

  2. ご回答ありがとうございます。
    なるほど、承知いたしました。
    自分はルータと書いたので、一縷の望みを持ったのですが違ってそうですね。。
    ありがとうございました!

    • 私も今回始めて試したので、他の方の意見も聞いてみたいですね…
      こちらこそコメントありがとうございました!

タイトルとURLをコピーしました